بالا نیامدن عجیب بدون هیچ کار خاصی !

سرورهایی که بر پایه ردهت، سنت‌او‌اس و فدورا هستند.
آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » پنج شنبه 26 فروردین 1395, 7:59 pm

سلام وقتی توی گراب وارد لینوکس میشم بعد از 30 ثانیه که loading تمام میشه به جای صفحه login یک صفحه سیاه میاد و هیچ اتفاقی نمیافته !!!
تا یک روز قبل هیچ مشکلی وجود نداشت و فقط یک ساعت وبگردی داشتم و یک فیلم نگاه کردم ولی الان خود به خود اینطوری شده توی همون صفحه سیاه دکمه های ctrl+alt+f2 رو که میزنم وارد خط فرمان میشم و الان میخوام مشکل رو پیدا کنم لطفا راهنمایی کنید ؟
(rhel 7.1 نصب کردم.)
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » جمعه 26 فروردین 1395, 2:51 am

عجیبه توی centos 7(1503) هم باز به همین مشکل برخوردم این فایل log رو چطوری توی خط فرمان پیدا کنم و دلیل بالا نیامدن صفحه login رو بفهمم ؟
میخوام بدونم کدام برنامه باعث میشه که به جای صفحه login یک صفحه سیاه بیاد و هیچ اتفاقی نیافته ؟!!!
(جالبه بعد از زدن دکمه های ctrl+alt+f2 و وارد شدن به کاربر root و زدن دستور startx بازم صفحه سیاه میاد !؟)
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط hedayat » جمعه 27 فروردین 1395, 1:45 pm

یه نگاهی به محتوای var/log/Xorg.0.log/ بنداز ببین پیام خطایی چیزی نداره؟! عمدتا باید با (EE) یا (WW) شروع بشه.

آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » شنبه 28 فروردین 1395, 1:43 pm

اسم برنامه ای که باعث این مشکل شده نبود !؟
این فایل های پوشه ی log :
http://s6.picofile.com/file/8247421250/log.zip.html
من دوتا فایل با این نام دارم به نام های Xorg.0 و Xorg.0.log.old کدام رو بگردم ؟
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط hedayat » شنبه 28 فروردین 1395, 9:35 pm

من کلا یک دونه فایل گفتم! چرا یک شاخه فرستادید؟ بعد هم می‌پرسید کدوم فایل؟! x(
همون رو گشته بودید این خطا توش بود:
کد: انتخاب همه
[    30.511] (EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]

یا درایور ati/amd نصب کردید (که درست نصب نشده) یا یه چیزی نصب کردید که فایل‌های اون رو پاک کرده!

آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » یکشنبه 28 فروردین 1395, 1:15 am

ببخشید اخه با فدورا لایو رفتم دیدم چندتا فایل لاگ وجود داره دست پاچه شدم یه دفه نمیدونستم چکار کنم همه رو کپی کردم.
اره درسته ولی من حدودا سه یا چهار روز قبل این درایور رو به صورت زیر نصب کردم از یک مخزنی به نام EPLE Repo :
کد: انتخاب همه
yum --enablerepo=elrepo-testing install fglrx-x11-drv
yum remove xorg-x11-glamor

خیلی جالبه درایور روی RHEL 7.1 فقط سه روز کار کرد ! :-(
و روی Centos 7 (1503) فقط یک روز کار کرد ! :((
من طبق این سایت اول میخواستم نصب کنم ولی مینوشت درایور وجود نداره بعد که گشتم طبق سایت دوم از مخزن های تست نصب شد :
سایت اول :
https://elrepo.org/tiki/kmod-fglrx
سایت دوم :
https://pkgs.org/centos-7/elrepo-testing-x86_64/fglrx-x11-drv-15.12-3.el7.elrepo.x86_64.rpm.html
و هر دوتا سایت هم نوشتن که این درایور روی centos و rhel نصب میشه !
برم دوباره نصب کنم شاید با نصب درایور روی درایور اگه فایلی پاک یا خراب شده باشه دوباره تعمیر بشه و بالا بیاد .
راستی هدایت جان ممکنه به خاطر این دستور گلامور باشه :
کد: انتخاب همه
yum remove xorg-x11-glamor

این گلامور همون درایور پیش فرض centos و rhel هست درسته ؟
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط hedayat » یکشنبه 29 فروردین 1395, 8:22 am

بعید نیست به خاطر همون glamor باشه. به نظر نمیاد نیازی به حذفش داشته باشید!
https://www.freedesktop.org/wiki/Software/Glamor

این یه درایور ۲بعدیه که روی درایورهای ۳بعدی کار میکنه که دیگه کارت‌های گرافیکی نیازی به داشتن یه درایور ۲بعدی مجزا نداشته باشند.

آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » یکشنبه 29 فروردین 1395, 11:04 am

توی این لینک در اخرین پست صفحه اول نوشته بود :
https://www.centos.org/forums/viewtopic.php?f=48&t=47494
منم فک کردم شاید باید پاک بشه :-( البته بعد از اینکه به مشکل برخوردم چون روی rhel نصب کرده بودم راهنمایی نکردن حتی بعد از نصب روی centos بازم راهنمایی نکردن!(داداش هدایت یک دنیا ازت ممنونم که کمکم میکنی واقعا ممنونم♥).
البته یک موردی گفته شده به نام Secure Boot issue که باید روی مادربورد غیر فعال بشه ایا مادربورد asus چنین چیزی داره و همچین کاری نیاز هست ؟
کد: انتخاب همه
1. Reboot the system and disable "Secure Boot" (a UEFI thing for Windows) in the motherboard BIOS, else you get errors (a) during boot that a X.509 certificate in the kernel is missing and (b) later a modprobe error that it "could not insert 'fglrx': Required key not available." Note: Both messages point to a Secure Boot issue.

دوباره نصب میکنم ولی این دفه گلامور رو پاک نمیکنم ولی سه تا سوال فنی دارم :
1-درایور دیگه ای در مخزن دیگه ای وجود داره که نصب کنم اگه اره لطفا اسم مخزن رو بگید ؟(چون درایوری که در این مخزن هست ظاهرا در حال تست هست !)
2-تفاوت درایور که توی سایت خود AMD/ATI هست با این درایورهایی که در مخازن هست چیه و کدام یکی بهتره ؟
3-هدایت جان شما درایور ATI رو از سایت AMD/ATI نصب میکنی یا از مخزن ها ؟
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط hedayat » یکشنبه 29 فروردین 1395, 7:01 pm

نمیدونم شایدم مشکل از این نیست! بالاخره بهتره هر وقت چیزی رو remove میکنید دقیق نگاه کنید چه چیزهایی پاک میشه.
خواهش میکنم! :)
من راستش خیلی وقته با کارت ATI/AMD سر و کار نداشتم!
در مورد اون secure boot هم اگه اون خطایی که نوشته رو دیدید برید سرش وگرنه کاری باهاش نداشته باشید فعلا! هر چند میتونید تستش کنید.
معمولا درایوری که توی مخازن هست همون درایور سایت nvidia هست ولی با اون توزیع کاملا تطبیق داده شده که نصبش راحت‌تر و بی‌دردسرتر باشه. ولی می‌تونید از همون اصلیه هم استفاده کنید (ممکنه یه سری فرآیند دستی بعد نصب اون لازم باشه).

آواتار کاربر
پست: 786
تاریخ عضویت: پنج شنبه 27 اسفند 1388, 2:46 pm
محل اقامت: شوشتر

Re: بالا نیامدن عجیب بدون هیچ کار خاصی !

پستتوسط sajjads24 » چهارشنبه 1 اردیبهشت 1395, 6:07 pm

هدایت جان اون درایور که توی مخازن بود رو هر کاری کردم راه نیوفتاد حالا اومدم دوباره سر درایور باینری خود ATI فقط یک سوال در مورد log بعد از نصب :
کد: انتخاب همه
[[email protected] ~]$ su
Password:
[[email protected] sajjad]# cat /usr/share/ati/fglrx-install.log
Supported adapter detected.
Check if system has the tools required for installation.
Uninstalling any previously installed drivers.
Unloading radeon module...
rmmod: ERROR: Module radeon is in use
Unloading drm module...
rmmod: ERROR: Module drm is in use by: ttm drm_kms_helper radeon
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.10.0-229.el7.x86_64/build SUBDIRS=/usr/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/kernels/3.10.0-229.el7.x86_64'
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
/usr/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c: In function ‘KCL_ACPI_No_Hotplug’:
/usr/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:861:22: warning: unused variable ‘pdev’ [-Wunused-variable]
     struct pci_dev  *pdev = (struct pci_dev*)dev;
                      ^
/usr/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c: At top level:
/usr/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:839:20: warning: ‘KCL_ACPI_Slot_No_Hotplug’ defined but not used [-Wunused-function]
 static acpi_status KCL_ACPI_Slot_No_Hotplug(KCL_ACPI_DevHandle handle, u32 lvl, void *data, void **rv)
                    ^
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl.o
  CC [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
  LD [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /usr/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/kernels/3.10.0-229.el7.x86_64'
build succeeded with return value 0
duplicating results into driver repository...
done.
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
- recreating module dependency list
- trying a sample load of the kernel modules
done.
[Reboot] Kernel Module : dracut
[[email protected] sajjad]# cd /lib/modules/fglrx
[[email protected] fglrx]# ./make_install.sh
- recreating module dependency list
- trying a sample load of the kernel modules
done.
[[email protected] fglrx]#

در پیام خطایی که در نصبش بوده ماژول های هسته لود نشده ایا راهی هست که بتونم این ماژول های هسته رو به صورت دستی به درایور شناسایی کنم که این ارور ماژول رفع بشه ؟
برای اینکه بت پرستی نباشی ، کافی
نیست که بت ها را شکسته باشی ، باید
خوی بت پرستی را ترک گفته باشی .
"نیچه"

بعدی

بازگشت به ردهت

چه کسی آنلاین است

کاربران حاضر در این انجمن : کاربر عضو شده ای موجود نیست و 1 مهمان