pdf highlighter (حل شد)

مشکلات در مورد نرم‌افزارهای مختلف
پست: 210
تاریخ عضویت: پنج شنبه 19 مرداد 1391, 6:07 pm

pdf highlighter (حل شد)

پستتوسط moji_helooo » شنبه 24 اردیبهشت 1395, 2:26 am

سلام.
نرم افزاری هست تحت فدورا که امکان highlight کردن داشته باشه؟

اون نرم افزار رو چطور دانلود و نصب کنم؟

تشکر
آخرین بار توسط moji_helooo در پنج شنبه 30 اردیبهشت 1395, 1:35 pm ویرایش شده است، در کل 1 بار ویرایش شده است.

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: pdf highlighter

پستتوسط hedayat » شنبه 25 اردیبهشت 1395, 10:10 pm

تو فدورا ۲۳ برنامه‌ی پیش‌فرض گنوم (evince) قابلیت highlight هم داره!

پست: 210
تاریخ عضویت: پنج شنبه 19 مرداد 1391, 6:07 pm

Re: pdf highlighter

پستتوسط moji_helooo » دوشنبه 27 اردیبهشت 1395, 2:14 pm

خب من فدورا ۲۲ دارم. ۲۳ نصب کردم خیلی باگ داشت. منتظر ۲۴ش هستم.
نمی‌تونم این رو روی ۲۲ نصب کنم؟

معاونت سایت
آواتار کاربر
پست: 6436
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: pdf highlighter

پستتوسط hedayat » سه شنبه 28 اردیبهشت 1395, 8:46 am

نمیدونم میتونید تلاش کنید!

پست: 210
تاریخ عضویت: پنج شنبه 19 مرداد 1391, 6:07 pm

Re: pdf highlighter

پستتوسط moji_helooo » سه شنبه 28 اردیبهشت 1395, 4:51 pm

این پکیج رو از اینجا دان کردم: http://linux.softpedia.com/get/Text-Edi ... l#download
توی فولدرش یه پوشه‌ی build ساختم و توش configure زدم. کلی وسطش پکیج miss داد و نصب کردم. الان رسیده به اینجا. نمی‌دونم چی کار کنم.

کد: انتخاب همه
.
.
.
checking for inflate in -lz... yes
checking for crc32 in -lz... yes
checking for LIBDOCUMENT... no
configure: error: Package requirements (gtk+-3.0 >= 3.16.0 gio-2.0 >= 2.36.0 gmodule-no-export-2.0 >= 2.36.0 gmodule-2.0) were not met:

No package 'gtk+-3.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDOCUMENT_CFLAGS
and LIBDOCUMENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

آواتار کاربر
پست: 34
تاریخ عضویت: چهارشنبه 15 مرداد 1387, 1:52 am
محل اقامت: /etc/

Re: pdf highlighter

پستتوسط Erix » چهارشنبه 29 اردیبهشت 1395, 11:40 am

یاید همه dependensies های مورد نیاز رو نصب کنید هرچیزی که میگه missing!!
از سایت سازنده هم برید حتما پکیجهای مورد نیاز رو لیست کرده

پست: 210
تاریخ عضویت: پنج شنبه 19 مرداد 1391, 6:07 pm

Re: pdf highlighter

پستتوسط moji_helooo » پنج شنبه 29 اردیبهشت 1395, 12:49 am

خب منم هر چی می‌گفت رو نصب کردم. بعضی‌هاش هم حتا کلی دردسر داشتن. اما نمی‌دونم اینکه می‌گه:


installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDOCUMENT_CFLAGS
and LIBDOCUMENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

یعنی چی؟
یعنی باید چی کار دارم.
تازه اون پکیج‌های +gtk و اینا رو همه رو دارم. هر چی در موردش بود نصب کردم. ولی بازم گیر داره.

پست: 210
تاریخ عضویت: پنج شنبه 19 مرداد 1391, 6:07 pm

Re: pdf highlighter

پستتوسط moji_helooo » پنج شنبه 30 اردیبهشت 1395, 1:35 pm

yeeeeeeeeeeeeeesssssssssss

تونستم. خیلی dependency نصب کردم. برای gtk+-3 باید به صورت gtk3 دنبالش می‌گشتم. اون + رو نباید می‌ذاشتم. الان من pdf highlighter دارم.
مرسی از راهنمایی‌هاتون. @};- @};- @};-

بازگشت به نرم‌افزار

چه کسی آنلاین است

کاربران حاضر در این انجمن : کاربر عضو شده ای موجود نیست و 8 مهمان