مشکل با Wine

مشکلات در مورد نرم‌افزارهای مختلف
پست: 203
تاریخ عضویت: پنج شنبه 18 اسفند 1389, 12:13 am
محل اقامت: اصفهان

مشکل با Wine

پستتوسط Akbar » دوشنبه 26 مهر 1395, 11:13 pm

سلام
من از centos 7 64-bit استفاده میکنم و جدیدا برنامه wine1.8.4 (آخرین نسخه مخازن) را از مخازن نصب کرده ام ولی هر فایل Exe که با آن اجرا میکنم پیغام خطای زیر صادر میشود.
برای مثال :
$ wine MofidTrader-5.exe
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
wine: Bad EXE format for Z:\home\akbar\Downloads\MofidTrader-5.exe.

معاونت سایت
آواتار کاربر
پست: 6439
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: مشکل با Wine

پستتوسط hedayat » سه شنبه 27 مهر 1395, 11:53 am

wine.i686 رو هم نصب کنید ممکنه مشکل بحث ۳۲/۶۴بیت باشه.

پست: 203
تاریخ عضویت: پنج شنبه 18 اسفند 1389, 12:13 am
محل اقامت: اصفهان

Re: مشکل با Wine

پستتوسط Akbar » پنج شنبه 29 مهر 1395, 10:50 pm

hedayat نوشته است:wine.i686 رو هم نصب کنید ممکنه مشکل بحث ۳۲/۶۴بیت باشه.


خودم هم همین نظر را دارم ولی وقتی دستور نصب میزنم می گوید:
No package wine.i686 available

معاونت سایت
آواتار کاربر
پست: 6439
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: مشکل با Wine

پستتوسط hedayat » جمعه 30 مهر 1395, 5:50 pm

آهان البته مطمئن نیستم centos هم i686 باشه. شاید i586 یا i386 باشه. اصلا یه *yum list wine بگیرید ببینین تو لیستش چیا هست؟

پست: 203
تاریخ عضویت: پنج شنبه 18 اسفند 1389, 12:13 am
محل اقامت: اصفهان

Re: مشکل با Wine

پستتوسط Akbar » شنبه 1 آبان 1395, 7:40 pm

hedayat نوشته است:آهان البته مطمئن نیستم centos هم i686 باشه. شاید i586 یا i386 باشه. اصلا یه *yum list wine بگیرید ببینین تو لیستش چیا هست؟


کد: انتخاب همه
yum list wine*
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.centos.org
 * epel: epel.scopesky.iq
 * extras: mirror.centos.org
 * nux-dextop: li.nux.ro
 * rpmforge: ftp.kddilabs.jp
 * updates: mirror.centos.org
Installed Packages
wine.x86_64                                   1.8.4-1.el7             @epel     
wine-alsa.x86_64                              1.8.4-1.el7             @epel     
wine-capi.x86_64                              1.8.4-1.el7             @epel     
wine-cms.x86_64                               1.8.4-1.el7             @epel     
wine-common.noarch                            1.8.4-1.el7             @epel     
wine-core.x86_64                              1.8.4-1.el7             @epel     
wine-courier-fonts.noarch                     1.8.4-1.el7             @epel     
wine-desktop.noarch                           1.8.4-1.el7             @epel     
wine-filesystem.noarch                        1.8.4-1.el7             @epel     
wine-fixedsys-fonts.noarch                    1.8.4-1.el7             @epel     
wine-fonts.noarch                             1.8.4-1.el7             @epel     
wine-ldap.x86_64                              1.8.4-1.el7             @epel     
wine-marlett-fonts.noarch                     1.8.4-1.el7             @epel     
wine-ms-sans-serif-fonts.noarch               1.8.4-1.el7             @epel     
wine-openal.x86_64                            1.8.4-1.el7             @epel     
wine-pulseaudio.x86_64                        1.8.4-1.el7             @epel     
wine-small-fonts.noarch                       1.8.4-1.el7             @epel     
wine-symbol-fonts.noarch                      1.8.4-1.el7             @epel     
wine-system-fonts.noarch                      1.8.4-1.el7             @epel     
wine-systemd.noarch                           1.8.4-1.el7             @epel     
wine-tahoma-fonts.noarch                      1.8.4-1.el7             @epel     
wine-twain.x86_64                             1.8.4-1.el7             @epel     
wine-wingdings-fonts.noarch                   1.8.4-1.el7             @epel     
Available Packages
wine-devel.x86_64                             1.8.4-1.el7             epel     
wine-sysvinit.noarch                          1.8.4-1.el7             epel     
wine-tahoma-fonts-system.noarch               1.8.4-1.el7             epel     
wine-wingdings-fonts-system.noarch            1.8.4-1.el7             epel     
winexe.x86_64                                 1.00-2.4                nux-dextop
winexe-debuginfo.x86_64 


خروجی به شکل بالا است. ظاهرا بسته های i686 نداره.
شاید نیاز به مخزن جداگانه ای باشه

معاونت سایت
آواتار کاربر
پست: 6439
تاریخ عضویت: دوشنبه 21 مرداد 1387, 11:47 pm
محل اقامت: اصفهان

Re: مشکل با Wine

پستتوسط hedayat » یکشنبه 2 آبان 1395, 11:53 am

عجب! نمیدونم.
یه راه که البته باید محتاط بود توش اینه که مخازن epelه ۳۲بیتی رو هم فعال کنید و wine رو سعی کنید نصب کنید. ولی نمیدونم مثل مخازن فدورا هست که همزمان بشه wineه ۳۲ و ۶۴بیت رو نصب کرد یا نه. یه گشتی بزنید!

بازگشت به نرم‌افزار

چه کسی آنلاین است

کاربران حاضر در این انجمن : کاربر عضو شده ای موجود نیست و 0 مهمان